Actualizacion webOS 2.0

From WebOS Internals

Jump to: navigation, search


Contents

Introducción

Con la llegada del webOS Doctor 2.1.0 de HP para los dispositivos Pre+ de O2 y Vodafone, existe ahora un modo legal de obtener e instalar webOS 2.1 dentro de los dispositivos antiguos de los operadores de telefonía que no han entregado la actualización a 2.x. Los dispositivos compatibles incluyen a todos los equipos Pre y Pre Plus. Esta actualización no es compatible con los dispositivos Pixi.

Debes leer esta página de principio a fin dos veces antes de empezar este procedimiento. Debes completar todos los pasos del 0 al 6. No debes omitir ningún paso. No improvises. No pienses que puedes ignorar las instrucciones. Si no sigues las instrucciones de manera precisa, completamente y sin errores, no lograrás tu cometido y molestarás a mucha gente con preguntas innecesarias en el proceso.

Renuncia de Responsabilidad

Este es un proceso que utiliza software oficial de HP de forma no oficial. Deberás estar siempre preparado para la remota posibilidad de que la información de tu dispositivo sea borrada completamente y que tu perfil de Palm pueda llegar a ser destruido permanentemente. No procedas a menos que hayas realizado los respaldos pertinentes y estés de acuerdo con esta advertencia. Un conocimiento previo de MetaDoctor y Linux en general es bienvenido

Si tienes la necesidad de preguntar si deberías hacer esto en tu teléfono primario, mejor no lo hagaz, pues esto indica que no has tomado aún las precauciones ni realizado los respaldos en caso de que algo llegase a salir mal.

Otros Tutoriales

Ten en cuenta que esta página wiki es siempre la fuente autorizada de información acerca de este proceso, por lo que debes referirte a esta primera página para todas las instrucciones. Éstas son algunas otras páginas que pueden serte de utilidad, además de esta página. No reemplazan la información en esta página, que debes leer de principio a fin primero.

Tutoriales que han sido actualizados para estar de acuerdo con las instrucciones más recientes

La usuaria @malpha de PreCentral grabó un video de dos partes donde muestra los pasos de esta actualización paso a paso. Los videos pueden ser encontrados aquí (inglés).

Tutoriales que se encuentran sin actualizar y en los cuales no se debería confiar

El usuario @djwhitey de PreCentral grabó una guía paso a paso en inglés (Incluye errores de activación). {Sprint Pre-, Win7 x86, Ubuntu Server 10.04}
El usuario @innocentbystander de PreCentral ha escrito una guía completa para instalar y construir el MetaDoctor bajo Mac OS 10.6 para aquellos que tengan poca experiencia con la línea de comando. Se puede encontrar aquí (inglés).

Usando los scripts de Meta Doctor

Paso 0: Respalda tu dispositivo

Asegurate de tener copias de todos los datos que desees preservar de tu Perfil Palm. Existe la posibilidad de que debas borrar la información de tu Perfil Palm para tener éxito en esta actualizacion, así que debes actuar como si esto fuera a pasar desde el inicio.

También, asegúrate de correr la aplicacion Save/Restore de Preware para respaldar los datos de tus aplicaciones - no desearás perder tu progreso en Angry Birds, ¿o si?

Por supuesto, copia todos los archivos del drive USB de tu teléfono a tu PC para mantenerlos a salvo, incluyendo música, descargas y fotos. El webOS Doctor tiene la costumbre de eliminar tu unidad USB sin advertencia, así que debes actuar como si esto fuera a pasar desde el inicio.

Si tu teléfono usa el Perfil Palm como el lugar por defecto para los contactos, tal vez desees exportarlos de forma manual. Para saber cuantos contactos tienes en tu Perfil Palm: Aplicación Contactos -> Preferencias y Cuentas -> tocar "Perfil Palm" bajo la subsección "cuentas".

Para exportar los contactos de forma manual, lee este mensaje: PreCentral Forums - How To Transfer contacts (Inglés)

Una guía en inglés para usar Save/Restore puede encontrarse aquí.

Paso 1: Requisitos de Instalación

  • Espacio en Disco Duro - Deberías tener al menos 10Gb de espacio en disco duro para realizar estos pasos.
  • MetaDoctor - ver Application:MetaDoctor-ES para información de como instalar Meta Doctor.

Toma en cuenta que el procedimiento para la actualización a webOS 2.0 está en esta página. El MetaDoctor es simplemente una herramienta para este procedimiento. Necesitas solo completar el paso 1: Instalando Meta-Doctor en aquella página. Cuando termines el Paso 1: Instalando Meta-Doctor en aquella página, deberás regresar a esta página y continuar el procedimiento en esta página.

Aunque el Palm SDK no es completamente necesario para completar este procedimiento, es la mejor forma de instalar los programas novacom y novaterm que son usados para transferir archivos a tu dispositivo y acceder a la línea de comando.

Paso 2: Preparar tu Perfil de Palm

Con combinaciones de proveedor de telefonía/dispositivo/Sistema Operativo que no sean soportadas, tal vez sea necesario eliminar algunos de los datos del Perfil de Palm para que se te sea permitido entrar a tu dispositivo en versión 2.x. El proceso es el siguiente: Precaución: esto eliminará datos de tu Perfil de Palm, incluyendo pero no limitado a: calendarios, contactos, información de cuentas, firmas de correo, marcadores del navegador, memos, tareas, mensajes SMS/MMS, y la ubicación de los iconos del lanzador de aplicaciones.

  1. Abrir la aplicación de Copia de Seguridad.
  2. Apagar la copia de seguridad, confirmando que deseas eliminar la información de tu Perfil Palm.

Este paso es extremadamente importante si notas que al terminar el Doctor y entrar a tu perfil, tus aplicaciones no se descargan de forma automática y el nombre de la cuenta de tu Perfil Palm en la sección Cuentas aparece como "Dr. Skipped Firstuse". Deberás borrar el respaldo de tu perfil y ejecutar el Doctor de nuevo.

NOTA: Los últimos scripts PODRÍAN realizar una conversión directa de un perfil 1.4.5 a 2.1.0 sin la necesidad de eliminar los datos del Perfil Palm. Por favor leer la información en "Perfil Palm" más abajo para entender los problemas que podrían resultar de intentar esto, así como las soluciones requeridas a dichos problemas.

Paso 3: Ejecutar el script MetaDoctor específico para tu dispositivo

Los scripts de MetaDoctor bajarán automáticamente los webOS doctors necesarios, extraerán y reemplazarán el firmware del radio CDMA si es necesario, y construirán y ejecutarán el webOS Doctor modificado.

NOTA: Si esta no es tu primera vez realizando este proceso, deberías teclear "git pull" y un "make clobber" para asegurarte de tener los últimos scripts y un directorio de compilación limpio. Desde la línea de comando, teclea "cd meta-doctor" sin las comillas y presiona Enter. Después teclea "git pull" sin las comillas y presiona Enter. Después teclea "make clobber" sin las comillas y presiona Enter. Voila! Ahora tienes los scripts más recientes y un directorio limpio para construir tu Doctor.

Desde el directorio meta-doctor, ejecuta el script meta que corresponde a tu dispositivo (toma en cuenta que el texto entre el < y el > en la línea siguiente deben ser sustituirlos por valores que tu proporcionarás - no puedes teclear exactamente el texto como se muestra)

./scripts/

Deberás reemplazar <operador>, <dispositivo> y <version> con los valores específicos que corresponden a tu situación particular, usanro la información detallada que se proporciona en la sección siguiente.

Un listado de todos los scripts se pueden encontrar tecleando

ls ./scripts/


Para aquellos que por alguna razón no puedan activar sus teléfonos y necesiten saltarse la aplicación de primer uso y habilitar Wifi para entrar a sus perfiles, simplemente deberán agregar la opción --wifi-only al ejecutar el script:

./scripts/meta-<operador>-<dispositivo>-<version> --wifi-only

De igual forma, deberás reemplazar <operador>, <dispositivo> y <version> con los valores específicos que corresponden a tu situación particular, usanro la información detallada que se proporciona en la sección siguiente.

Una vez que tu dispositivo encienda después del paso 4, lo único que necesitarás es configurar y encender la red wifi y ejecutar el Tutorial de Trazos (Gesture Tutorial) y estarás listo. Nota que en este caso al final del procedimiento de login al perfil el proceso aparentará estar trabado, así que simplemente reinicia tu dispositivo usando la combinación Opt-Sym-R en el teclado.

Información adicional específica para cada una de las combinaciones de dispositivos y operadores se puede encontrar a continuación:

AT&T Pre+

./scripts/meta-att-preplus-2.1.0

Terminarás con versión 1.40.50 en tu Perfil Palm, y versión 2.1.0 en la aplicación Información de Dispositivo.

No podrás comprar aplicaciones que requieran una versión mínima de webOS 2.x.

BellMo Pre

./scripts/meta-bellmo-pre-2.1.0

Terminarás con versión 1.40.50 en tu Perfil Palm, y versión 2.1.0 en la aplicación Información de Dispositivo.

No podrás comprar aplicaciones que requieran una versión mínima de webOS 2.x.

O2 Pre

./scripts/meta-o2-pre-2.1.0

Terminarás con versión 2.1.0 en tu Perfil Palm, y versión 2.1.0 en la aplicación Información de Dispositivo.

Deberías poder comprar aplicaciones que requieran una versión mínima de webOS 2.x (dependiendo de las restricciones del país de la activación inicial de tu dispositivo).

O2 Pre+

./scripts/meta-o2-preplus-2.1.0

Terminarás con versión 2.1.0 en tu Perfil Palm, y versión 2.1.0 en la aplicación Información de Dispositivo.

Deberías poder comprar aplicaciones que requieran una versión mínima de webOS 2.x (dependiendo de las restricciones del país de la activación inicial de tu dispositivo).

Sprint Pre

Toma en cuenta que no hay una solución disponible públicamente para Sprint Navigarion o la actualización de Sprint PRL para este procedimiento. Si dependes de alguna de estas cosas, no deberías actualizar a webOS 2.1.0

./scripts/meta-sprint-pre-2.1.0

Terminarás con versión 2.1.0 en tu Perfil Palm, y versión 2.1.0 en la aplicación Información de Dispositivo.

Deberías poder comprar aplicaciones que requieran una versión mínima de webOS 2.x (dependiendo de las restricciones del país de la activación inicial de tu dispositivo).

Sprint Pre 2

Toma en cuenta que no hay una solución disponible públicamente para Sprint Navigarion o la actualización de Sprint PRL para este procedimiento. Si dependes de alguna de estas cosas, no deberías actualizar a webOS 2.1.0

./scripts/meta-sprint-pre2-2.0.1

Terminarás con versión 2.0.1 en tu Perfil Palm, y versión 2.0.1 en la aplicación Información de Dispositivo.

Deberías poder comprar aplicaciones que requieran una versión mínima de webOS 2.x (dependiendo de las restricciones del país de la activación inicial de tu dispositivo).

Telcel Pre

./scripts/meta-telcel-pre-2.1.0

Terminarás con versión 1.40.00 en tu Perfil Palm, y versión 2.1.0 en la aplicación Información de Dispositivo.

No podrás comprar aplicaciones que requieran una versión mínima de webOS 2.x.

Verizon Pre+

./scripts/meta-verizon-preplus-2.1.0

PODRÍAS obtener versión 2.1.0 en tu Perfil Palm (usando los últimos scripts - ejecuta un "git pull" en el directorio meta-doctor), y OBTENDRÁS versión 2.1.0 en la aplicación Información de Dispositivo.

PODRÍAS ser capaz de comprar aplicaciones que requieran una versión mínima de 2.x.

Para actualizar tu PRL, necesitarás programar tu teléfono de forma manual marcando *228, y seleccionando "Programar su teléfono".

WR Pre

Para los dispositivos WR, puedes intentar usar el script para O2 mencionado anteriormente, y si terminas con una versión 9.9.9 en tu Perfil Palm, entonces usa este script en su lugar.

./scripts/meta-wr-pre-2.1.0

Terminarás con versión 1.40.50 en tu Perfil Palm, y versión 2.1.0 en la aplicación Información de Dispositivo.

No podrás comprar aplicaciones que requieran una versión mínima de webOS 2.x.

Paso 4: Ejecutar el webOS Doctor modificado

El meta-script automaticamente iniciará el webOS Doctor por tí. Sin embargo, si necesitas moverlo a una ubicación diferente y ejecutarlo manualmente, el doctor modificado será un archivo .jar localizado en el directorio de salida build:

meta-doctor/build/preplus-p101ueude-wr-2.1.0/webosdoctorp101ueude-wr-2.1.0.jar

Toma en cuenta que la ruta del directorio será diferente al ejemplo basado en el script que uses, y el script te dirá la ruta correcta al iniciar el proceso.

No conectes el teléfono a tu puerto USB hasta que el webOS Doctor te lo especifique.

Paso 5: No hay Paso 5

Había anteriormente una combinación de pasos complicados aquí. Mucha gente tenía problemas para seguirlos, así que lo automatizamos. Deberás proceder directamente al Paso 6.

Paso 6: Dona a WebOS Internals y compra la aplicación Preware Homebrew Documentation app

Si esta información te ha servido, apreciaremos una donación en http://donate.webos-internals.org - y si deseas agradecer a Rod Whitby personalmente por las largas horas que ha dedicado para crear el Meta-Doctor y este procedimiento de actualización, deberías comprar la Preware Homebrew Documentation del catálogo oficial de aplicaciones, y dejar una reseña de 5 estrellas con tu mensaje de agradecimiento.

Advertencias

Catálogo de Aplicaciones

  • Las aplicaciones que están marcadas como solo compatibles con las versiones de webOS 2.x o superiores no aparecerán con algunas de estas instalaciones de webOS 2.1.0. En algunos dispositivos/operadores, se utiliza una técnica de enmascaramiento para que el Perfil Palm reporte aún versión 1.40.50.

Enmascaramiento

Los servidores de Palm sólo aceptan ciertas combinaciones de dispositivo/versión como válidas. Mientras que los dispositivos Pre y Pre Plus ROW (Rest of World, usados en Europa) que corran 2.1 son aceptados, los dispositivos Pre y Pre Plus que corren en Sprint, Verizon, AT&T, y Telcel, deben enmascararse para aparentar que es una combinación de dispositivo/Sistema Operativo válido y permitir acceso al catálogo de aplicaciones. Esto se hace de forma automática, y no puede ser cambiado para estos dispositivos en este momento.

Aplicaciones específicas por Operador

  • Algunas aplicaciones específicas por Operador no funcionan correctamente en webOS 2.1. Las aplicaciones que se han probado y se sabe que instalan correctamente y funcionan se agregará a tu webOS Doctor para el dispositivo/Operador apropiado.

Aplicaciones de Operador que se sabe funcionan:

Sprint

  • Sprint Portal
  • Sprint TV
  • Sprint Football Live
  • NASCAR

Verizon Wireless

  • ¡Todas las aplicaciones de Verizon deberían estar funcionando en este momento! Sin embargo, nadie ha probado la subscripción a VZW Navigator para confirmar que el servicio se puede usar en un teléfono con Meta-Doctor. ¡Podrías ser el primero!

AT&T

  • No se han hecho pruebas o reportes de aplicaciones de AT&T

Parches

  • No todos los parches se han probado y portado aún. Si deseas revisar si algún parche está listo, por favor revisa el portal de parches de webOS de webOS-internals.

Flash

  • Adobe Flash no está incluido en esta versión del webOS 2.1 doctor, pero puede ser añadido con archivos de un Doctor de un Pre2 de Verizon Wireless.

Añadir Soporte Flash (Método Fácil)

La forma más fácil de tener Flash en tu dispositivo antiguo webOS 2.1.0 es vía la creación de un paquete modular junto con un parche que hace que Adobe Flash aparezca en las preferencias del navegador.


Agregar Soporte Flash de forma Manual

Paso 1. Requisitos

  • Descarga el Doctor para Pre 2 de Verizon 2.0.1 (aquí)
  • Descarga el Empaquetador IPK de Jason Robitaille's (aquí)
  • Descarga webOS Quick Install (aquí)
  • Descarga el archivo de directorio temporal (aquí) y descomprime el directorio FlashPluginContainer en tu escritorio
  • Descarga el parche para habilitar las preferencias de Flash en el navegador (aquí)

Paso 2. Desempacar

  • Abre el Doctor 2.0.1 con un manejador de archivos, como 7zip. Navega hasta "resources/webOS.tar/./nova-cust-image-roadrunner.rootfs.tar.gz/./" Aquí es donde se encuentran almacenados los archivos de Flash.
  • Extrae los siguientes archivos del ROM de webOS:
/etc/adobe/mms.cfg
/etc/adobe/oem.cfg
/usr/lib/BrowserServerPlugins/libflashplayer.so
/usr/lib/BrowserServerPlugins/resource/plugin-icon-noplay.png
/usr/lib/BrowserServerPlugins/resource/plugin-icon-play-down.png
/usr/lib/BrowserServerPlugins/resource/plugin-icon-play.png
/usr/lib/BrowserServerPlugins/resource/plugin-icon-unknown.png
/usr/lib/BrowserServerPlugins/resource/plugin-scrim.png
/usr/lib/libFlashGraphics.so
/usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-noplay.png
/usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-play.png
/usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-unknown.png
/usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-scrim.png
/usr/lib/BrowserServerPlugins/FlashMiniPlugin.so

Paso 3. Arrastrar y Tirar

  • Simplemente coloca los archivos del ROM dentro del directorio FlashPluginContainer en sus lugares respectivos.
  • Pon especial atención a donde se encuentra almacenado cada archivo/directorio en el ROM de webOS.

Paso 4. Empaquetar

  • Abre el IPK Packager de Jason y apunta el programa al directorio files. NO LO APUNTES al directorio FlashPluginContainer, pues la instalación fallará en tu Pre.
  • El resto de los campos deberá poblarse por sí mismo.
  • Graba el archivo IPK en algún lugar usando el botón "Create IPK Package". Colócalo en un lugar a la mano.

Paso 5. Final

  • Usa webOS Quick Install para instalar el paquete y el parche.


Hilo de soporte: http://forums.precentral.net/canuck-coding/276703-how-get-flash-legacy-devices-2-1-0-a.html (Inglés)


Agregar Soporte Flash de forma automatizada

1. Extraer WebOS.tar del folder Resources en el Doctor VZW a algún lugar en tu disco duro
2. Copiar los siguientes archivos del webOS.tar a sus lugares equivalentes en tu MetaDoctor (alternativamente, puedes copiarlos manualmente a un dispositivo vivo usando Novaterm)

/etc/adobe/mms.cfg
/etc/adobe/oem.cfg
/usr/lib/BrowserServerPlugins/libflashplayer.so
/usr/lib/BrowserServerPlugins/resource/plugin-icon-noplay.png
/usr/lib/BrowserServerPlugins/resource/plugin-icon-play-down.png
/usr/lib/BrowserServerPlugins/resource/plugin-icon-play.png
/usr/lib/BrowserServerPlugins/resource/plugin-icon-unknown.png
/usr/lib/BrowserServerPlugins/resource/plugin-scrim.png
/usr/lib/libFlashGraphics.so
/usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-noplay.png
/usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-play.png
/usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-unknown.png
/usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-scrim.png
/usr/lib/BrowserServerPlugins/FlashMiniPlugin.so

3. Abrir /usr/palm/applications/com.palm.app.browser/app/controllers/preferences-assistant.js (ya sea en tu MetaDoctor o en tu dispositivo vivo -si es en un dispositivo vivo recuerda hacer un respaldo!)
Entontrar las siguientes dos líneas (deben ser la 46 y 47) y comentarlas agregando // al principio de cara línea:

this.controller.get("flashPref").hide();
this.controller.get("autoLoadPref").hide();

4. Reiniciar tu Pre si la edición se hizo en un dispositivo vivo

Las opción de Flash deberían ser ahora visibles dentro de las preferencias del navegador.

Errores con Flash

Después de habilitar el soporte para Flash, puede ser que al visitar páginas con flash la página no termine de cargar, y después se refresque automáticamente de forma cíclica. Deberás deshabilitar y después volver a habilitar el contenido Flash en las preferencias de Flash en el navegador.

Desempeño

  • EL OVERCLOCKING YA ESTÁ SOPORTADO. Ahora que Palm ha liberado el código fuente para el kernel usado en webOS 2.1.0, los kernels personalizados ya están apareciendo en los feeds experimentales de Preware, sin embargo, los usuarios casuales deberín esperar una versión estable del UberKernel.
  • El Pre Plus tiene 512MB de memoria y corre 2.1 bastante bien, sin embargo, este no es el caso con el Pre osiginal, pues tiene sólamente 256MB. Afortunadamente, Palm adoptó la tecnologí compcache que fue portada a los kernels personalizados, y viene activa, pero sólo con 10MB. Una forma potencial de mejorar el desempeño en los Pre originales es hacer más grande este compcache.

Incrementar el tamaño del compcache, Método Temporal

Puedes usar la aplicación Govnah para incrementar el tamaño del compcache. Deshabilita compcache, cambia el tamaño y habilítalo de nuevo.

Incrementar el tamaño del compcache, Método Permanente

Deberás editar el archivo /etc/event.d/compcache en tu Pre y sustituir el valor 10240 por 32768, reinicia tu Pre y confirma que el cambio se realizó mediante la aplicación Govnah.

Por ejemplo, podrías seguir estos pasos:

  1. Asegúrate que novacomd esté ejecutándose en tu equipo.
  2. Usa una terminal y ejecuta novaterm para acceder tu teléfono. Teclea lo siguiente:
vi /etc/event.d/compcache
  1. Ve a la línea 10 y presiona 'i', borra 10240 y reemplázalo con 32768, presiona la tecla escape y a continuación presiona :wq y enter.
  2. Reinicia tu Pre y verifica que funciona con la aplicación Govnah.


Perfil de Palm

  • Algunas personas han tenido problemas al entrar a sus Perfiles Palm existentes en 2.1 debido a datos de respaldo. Para asegurarte de que puedas entrar a tu perfil en 2.1, deberías desactivar las copias de respaldo antes de ejecutar el Doctor de 2.1, y borrar la información que se encuentra en los servidores. Por supuesto, esto eliminará la mayoría de tus datos en el Perfil Palm (memos, tareas, entradas de calendario, cuentas...). Tus aplicaciones serán restauradas en 2.1, pero hasta ahí. Nota que no toda la gente tiene problemas con los respaldos. Si deseas no borrar tu copia de respaldo, puedes intentar hacer el Doctor a 2.1 sin desactivar los respaldos y ver si todo funciona. Si no, deberás regresar a la versión 1.4.5 para desactivar las copias de respaldo o usar un perfil nuevo.
  • Puedes tener suerte si tu Perfil tiene información y lograste pasar la pantalla de "Entrando al Perfil" pero te encuentras atorado con un mensaje que dice que tu teléfono no puede restaurar tus datos. Si tienes el modo de desarrollador habilitado, entra a tu teléfono con novaterm y sobreescribe el archivo /etc/palm-build-info con el archivo palm-build-info-masq que el script generó. Reinicia tu Pre y verifica si puede arrancar sin problemas (deberí bajar tus aplicaciones).
  • Si tienes versión 9.9.9 en palm.com/palmprofile , puedes usar el Doctor 1.4.5 para tu proveedor (1.4.0 para Telcel) y hacer Login, eliminar la información del respaldo de tu perfil y usar el meta-doctor 2.1.0, o puedes restaurar el archivo enmascarado /etc/palm-build-info para tu dispositivo, borrar la información en la aplicació de respaldos y usar "Eliminar Aplicaciones y Datos" de la opción reiniciar en la aplicación Información de Dispositivo
  • Si tienes el perfil dr. skipped firstuse como un Perfil Palm en la aplicación de Cuentas, y/o tu aplicación de Trazos (Gestures) crea una pantalla en blanco, tienes el problema del perfil falso. Debes ejecutar el Doctor de 1.4.5 (o 1.4.0) para tu Operador y hacer login, eliminar la información en la aplicación de respaldos y usar el meta doctor 2.1.0. Para evitar este problema, baja de nuevo la última versión del meta-doctor y ejecuta el script apropiado con la opción --wifi-only.
  • Otra opción para el problema anterior: Si tu perfil funciona correctamente pero la aplicación Impostah y la aplicación de Cuentas muestra tu perfil como Dr. Skipped First Use aunque el teléfono haya ejecutado la aplicación de primer uso al iniciar, asegúrate de que tu archivo /etc/palm-build-info te está enmascarando como 1.4.5, elimina tus datos en la aplicación de respaldos y selecciona Eliminar Aplicaciones y Datos de las opciones de reinicio en la aplicación Información de Dispositivo.
  • Si no puedes usar instalar el Palm SDK para usar el programa novacom y transferir archivos a tu dispositivo, puedes realizar el paso 5 alternativamente colocando dispositivo en modo USB, transfiriendo el archivo al directorio principal de tu drive USB, soltando el dispositivo USB (Eject), y usar la funcionalidad de "linux commandline" de Webos Quick Install 3.x para ejecutar los comandos alternativos del Paso 5 (no los de novacom).

GPS

  • Para habilitar la funcionalidad GPS, puede ser necesario ir a la aplicación "Servicios de Localización", y asegurarte que "GPS" y "Servicios de Localización GPS" esten habilitados. Realiza una prueba del GPS usando ##477# (##GPS#, o #*GPS# para GSM) desde la aplicación del Teléfono, y presiona el bot%oacute;n "Get Fix".
  • Si ni la utilidad ##477# ni Google Maps pueden encontrar tu posición correctamente, regresa a la aplicación "Servicios de localización", abre el menú Preferencias, expande Localizarme Usando... y asegúrate que tanto GPS como Servicios Goggle estén seleccionados. Una vez seleccionado Google Services, se te preguntará si deseas aceptar los Términos de Servicio de Google. Cuando las dos opciones estén seleccionadas, prueba la funcionalidad de GPS de nuevo. La utilidad ##477# puede fallar aún las primeras veces, pero debería completar con éxito después de varios intentos, y debería continuar funcionando normalmente.

PRL

  • Sprint - Despuén de aplicar 2.1.0 a un dispositivo de Sprint con este m´todo, no se sabe de un método para actualizar el PRL. Hay problemas de permisos, y las opciones convencionales "Actualizar Perfil" y "Actualizar PRL" del Teléfono ya no funcionan. El servicio binario del Doctor 1.4.5 de Sprint no funciona para webOS 2.x, así que una versión de ese servicio para 2.x se necesita para que esto llegue a funcionar.
  • Verizon - Para actualizar tu PRL, necesitas programar de forma manual tu teléfono OTA marcando al *228 y seleccionando la opci&oacute "Program your phone" (Programar su Teléfono).
Personal tools
Google AdSense